dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Wolfgang Bumiller <w.bumiller@proxmox.com>
|
|
Date: Mon, 6 Apr 2020 12:16:36 +0200
|
|
Subject: [PATCH] PVE: [Config] rbd: block: rbd: disable
|
|
rbd_cache_writethrough_until_flush
|
|
|
|
Either the cache mode asks for a cache or not. There's no
|
|
point in having a "temporary" cache mode. This option AFAIK
|
|
was introduced as a hack for ancient virtio drivers. If
|
|
anything, we should have a separate option for it. Better
|
|
yet, VMs affected by the related issue should simply
|
|
explicitly choose writethrough.
|
|
|
|
Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
|
|
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
|
|
---
|
|
block/rbd.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/block/rbd.c b/block/rbd.c
|
|
index 6caf35cbba..0cec24c86d 100644
|
|
--- a/block/rbd.c
|
|
+++ b/block/rbd.c
|
|
@@ -820,6 +820,8 @@ static int qemu_rbd_connect(rados_t *cluster, rados_ioctx_t *io_ctx,
|
|
rados_conf_set(*cluster, "rbd_cache", "false");
|
|
}
|
|
|
|
+ rados_conf_set(*cluster, "rbd_cache_writethrough_until_flush", "false");
|
|
+
|
|
r = rados_connect(*cluster);
|
|
if (r < 0) {
|
|
error_setg_errno(errp, -r, "error connecting");
|