dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
57 lines
1.9 KiB
Diff
57 lines
1.9 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Wolfgang Bumiller <w.bumiller@proxmox.com>
|
|
Date: Mon, 6 Apr 2020 12:16:33 +0200
|
|
Subject: [PATCH] PVE: [Config] ui/spice: default to pve certificates
|
|
|
|
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
|
|
---
|
|
ui/spice-core.c | 15 +++++++++------
|
|
1 file changed, 9 insertions(+), 6 deletions(-)
|
|
|
|
diff --git a/ui/spice-core.c b/ui/spice-core.c
|
|
index c3ac20ad43..37774f1c0a 100644
|
|
--- a/ui/spice-core.c
|
|
+++ b/ui/spice-core.c
|
|
@@ -689,32 +689,35 @@ static void qemu_spice_init(void)
|
|
|
|
if (tls_port) {
|
|
x509_dir = qemu_opt_get(opts, "x509-dir");
|
|
- if (!x509_dir) {
|
|
- x509_dir = ".";
|
|
- }
|
|
|
|
str = qemu_opt_get(opts, "x509-key-file");
|
|
if (str) {
|
|
x509_key_file = g_strdup(str);
|
|
- } else {
|
|
+ } else if (x509_dir) {
|
|
x509_key_file = g_strdup_printf("%s/%s", x509_dir,
|
|
X509_SERVER_KEY_FILE);
|
|
+ } else {
|
|
+ x509_key_file = g_strdup("/etc/pve/local/pve-ssl.key");
|
|
}
|
|
|
|
str = qemu_opt_get(opts, "x509-cert-file");
|
|
if (str) {
|
|
x509_cert_file = g_strdup(str);
|
|
- } else {
|
|
+ } else if (x509_dir) {
|
|
x509_cert_file = g_strdup_printf("%s/%s", x509_dir,
|
|
X509_SERVER_CERT_FILE);
|
|
+ } else {
|
|
+ x509_cert_file = g_strdup("/etc/pve/local/pve-ssl.pem");
|
|
}
|
|
|
|
str = qemu_opt_get(opts, "x509-cacert-file");
|
|
if (str) {
|
|
x509_cacert_file = g_strdup(str);
|
|
- } else {
|
|
+ } else if (x509_dir) {
|
|
x509_cacert_file = g_strdup_printf("%s/%s", x509_dir,
|
|
X509_CA_CERT_FILE);
|
|
+ } else {
|
|
+ x509_cacert_file = g_strdup("/etc/pve/pve-root-ca.pem");
|
|
}
|
|
|
|
x509_key_password = qemu_opt_get(opts, "x509-key-password");
|