dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
26 lines
841 B
Diff
26 lines
841 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Fabian Ebner <f.ebner@proxmox.com>
|
|
Date: Wed, 22 Jun 2022 10:45:12 +0200
|
|
Subject: [PATCH] vma: create: avoid triggering assertion in error case
|
|
|
|
error_setg expects its argument to not be initialized yet.
|
|
|
|
Signed-off-by: Fabian Ebner <f.ebner@proxmox.com>
|
|
---
|
|
vma-writer.c | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/vma-writer.c b/vma-writer.c
|
|
index df4b20793d..ac7da237d0 100644
|
|
--- a/vma-writer.c
|
|
+++ b/vma-writer.c
|
|
@@ -311,6 +311,8 @@ VmaWriter *vma_writer_create(const char *filename, uuid_t uuid, Error **errp)
|
|
}
|
|
|
|
if (vmaw->fd < 0) {
|
|
+ error_free(*errp);
|
|
+ *errp = NULL;
|
|
error_setg(errp, "can't open file %s - %s\n", filename,
|
|
g_strerror(errno));
|
|
goto err;
|