dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
36 lines
1.1 KiB
Diff
36 lines
1.1 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Fabian Ebner <f.ebner@proxmox.com>
|
|
Date: Thu, 23 Jun 2022 14:00:07 +0200
|
|
Subject: [PATCH] Revert "block/rbd: fix handling of holes in
|
|
.bdrv_co_block_status"
|
|
|
|
This reverts commit 9e302f64bb407a9bb097b626da97228c2654cfee in
|
|
preparation to revert 0347a8fd4c3faaedf119be04c197804be40a384b.
|
|
|
|
Signed-off-by: Fabian Ebner <f.ebner@proxmox.com>
|
|
---
|
|
block/rbd.c | 10 +++++-----
|
|
1 file changed, 5 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/block/rbd.c b/block/rbd.c
|
|
index 0a9b97aa5e..1c585d23e9 100644
|
|
--- a/block/rbd.c
|
|
+++ b/block/rbd.c
|
|
@@ -1283,11 +1283,11 @@ static int qemu_rbd_diff_iterate_cb(uint64_t offs, size_t len,
|
|
RBDDiffIterateReq *req = opaque;
|
|
|
|
assert(req->offs + req->bytes <= offs);
|
|
-
|
|
- /* treat a hole like an unallocated area and bail out */
|
|
- if (!exists) {
|
|
- return 0;
|
|
- }
|
|
+ /*
|
|
+ * we do not diff against a snapshot so we should never receive a callback
|
|
+ * for a hole.
|
|
+ */
|
|
+ assert(exists);
|
|
|
|
if (!req->exists && offs > req->offs) {
|
|
/*
|