dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Stefan Reiter <s.reiter@proxmox.com>
|
|
Date: Wed, 26 May 2021 15:26:30 +0200
|
|
Subject: [PATCH] PVE: whitelist 'invalid' QAPI names for backwards compat
|
|
|
|
Signed-off-by: Stefan Reiter <s.reiter@proxmox.com>
|
|
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
|
|
---
|
|
qapi/pragma.json | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/qapi/pragma.json b/qapi/pragma.json
|
|
index 41139d8645..a581acf7d4 100644
|
|
--- a/qapi/pragma.json
|
|
+++ b/qapi/pragma.json
|
|
@@ -15,6 +15,7 @@
|
|
'device_add',
|
|
'device_del',
|
|
'expire_password',
|
|
+ 'get_link_status',
|
|
'migrate_cancel',
|
|
'netdev_add',
|
|
'netdev_del',
|
|
@@ -63,6 +64,8 @@
|
|
'SysEmuTarget', # query-cpu-fast, query-target
|
|
'UuidInfo', # query-uuid
|
|
'VncClientInfo', # query-vnc, query-vnc-servers, ...
|
|
- 'X86CPURegister32' # qom-get of x86 CPU properties
|
|
+ 'X86CPURegister32', # qom-get of x86 CPU properties
|
|
# feature-words, filtered-features
|
|
+ 'BlockdevOptionsPbs', # for PBS backwards compat
|
|
+ 'BalloonInfo'
|
|
] } }
|