dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
60 lines
2.4 KiB
Diff
60 lines
2.4 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Fabian Ebner <f.ebner@proxmox.com>
|
|
Date: Wed, 2 Mar 2022 08:35:05 +0100
|
|
Subject: [PATCH] block/backup: move bcs bitmap initialization to job creation
|
|
|
|
For backing up the state of multiple disks from the same time, a job
|
|
for each disk has to be created. It's convenient if the jobs don't
|
|
have to be started at the same time and if operation of the VM can be
|
|
resumed after job creation. This would lead to a window between job
|
|
creation and running the job, where writes can happen. But no writes
|
|
should happen between setting up the copy-before-write filter and
|
|
setting up the block copy state bitmap, because then new writes would
|
|
just pass through.
|
|
|
|
Commit 06e0a9c16405c0a4c1eca33cf286cc04c42066a2 moved initalization of
|
|
the bitmap to setting up the copy-before-write filter when sync_mode
|
|
is not MIRROR_SYNC_MODE_BITMAP. Ensure that the bitmap is initialized
|
|
upon job creation for the remaining case too, by moving the
|
|
backup_init_bcs_bitmap call to backup_job_create.
|
|
|
|
Signed-off-by: Fabian Ebner <f.ebner@proxmox.com>
|
|
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
|
|
---
|
|
block/backup.c | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/block/backup.c b/block/backup.c
|
|
index 5cfd0b999c..07b899035c 100644
|
|
--- a/block/backup.c
|
|
+++ b/block/backup.c
|
|
@@ -239,8 +239,8 @@ static void backup_init_bcs_bitmap(BackupBlockJob *job)
|
|
assert(ret);
|
|
} else if (job->sync_mode == MIRROR_SYNC_MODE_TOP) {
|
|
/*
|
|
- * We can't hog the coroutine to initialize this thoroughly.
|
|
- * Set a flag and resume work when we are able to yield safely.
|
|
+ * Initialization is costly here. Simply set a flag and let the
|
|
+ * backup_run coroutine resume work once it can yield safely.
|
|
*/
|
|
block_copy_set_skip_unallocated(job->bcs, true);
|
|
}
|
|
@@ -254,8 +254,6 @@ static int coroutine_fn backup_run(Job *job, Error **errp)
|
|
BackupBlockJob *s = container_of(job, BackupBlockJob, common.job);
|
|
int ret;
|
|
|
|
- backup_init_bcs_bitmap(s);
|
|
-
|
|
if (s->sync_mode == MIRROR_SYNC_MODE_TOP) {
|
|
int64_t offset = 0;
|
|
int64_t count;
|
|
@@ -494,6 +492,8 @@ BlockJob *backup_job_create(const char *job_id, BlockDriverState *bs,
|
|
block_job_add_bdrv(&job->common, "target", target, 0, BLK_PERM_ALL,
|
|
&error_abort);
|
|
|
|
+ backup_init_bcs_bitmap(job);
|
|
+
|
|
return &job->common;
|
|
|
|
error:
|