dc9827a6a4
Only very minor changes needed: * Most patches in extra (or some version of them) are part of 7.0.0. * aio_set_fd_handler got an extra parameter, but can just pass NULL like we did for the related 'poll' parameter. See QEMU commit 826cc32423db2a99d184dbf4f507c737d7e7a4ae for more. * Add include for qemu/memalign.h in vma.c and vma-writer.c. * Add reverts for fixups of already reverted 0347a8fd4c ("block/rbd: implement bdrv_co_block_status") that came in with 7.0.0. Those fixups are not enough, see Proxmox bugzilla #4047. * Two trivial context changes for bitmap-mirror patches. * block_int.h got split up into multiple headers. * Some context changes in configure and meson.build. * Used the oppurtunity to squash fixup of bdrv_backuo_dump_create typo in a later patch into the patch introducing the function (had to move code to new header during rebase). Signed-off-by: Fabian Ebner <f.ebner@proxmox.com> Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
137 lines
5.0 KiB
Diff
137 lines
5.0 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Wolfgang Bumiller <w.bumiller@proxmox.com>
|
|
Date: Mon, 6 Apr 2020 12:16:43 +0200
|
|
Subject: [PATCH] PVE: virtio-balloon: improve query-balloon
|
|
|
|
Actually provide memory information via the query-balloon
|
|
command.
|
|
|
|
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
|
|
---
|
|
hw/virtio/virtio-balloon.c | 33 +++++++++++++++++++++++++++++++--
|
|
monitor/hmp-cmds.c | 30 +++++++++++++++++++++++++++++-
|
|
qapi/machine.json | 22 +++++++++++++++++++++-
|
|
3 files changed, 81 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/hw/virtio/virtio-balloon.c b/hw/virtio/virtio-balloon.c
|
|
index 163d244eb4..389907f1f8 100644
|
|
--- a/hw/virtio/virtio-balloon.c
|
|
+++ b/hw/virtio/virtio-balloon.c
|
|
@@ -813,8 +813,37 @@ static uint64_t virtio_balloon_get_features(VirtIODevice *vdev, uint64_t f,
|
|
static void virtio_balloon_stat(void *opaque, BalloonInfo *info)
|
|
{
|
|
VirtIOBalloon *dev = opaque;
|
|
- info->actual = get_current_ram_size() - ((uint64_t) dev->actual <<
|
|
- VIRTIO_BALLOON_PFN_SHIFT);
|
|
+ ram_addr_t ram_size = get_current_ram_size();
|
|
+ info->actual = ram_size - ((uint64_t) dev->actual <<
|
|
+ VIRTIO_BALLOON_PFN_SHIFT);
|
|
+
|
|
+ info->max_mem = ram_size;
|
|
+
|
|
+ if (!(balloon_stats_enabled(dev) && balloon_stats_supported(dev) &&
|
|
+ dev->stats_last_update)) {
|
|
+ return;
|
|
+ }
|
|
+
|
|
+ info->last_update = dev->stats_last_update;
|
|
+ info->has_last_update = true;
|
|
+
|
|
+ info->mem_swapped_in = dev->stats[VIRTIO_BALLOON_S_SWAP_IN];
|
|
+ info->has_mem_swapped_in = info->mem_swapped_in >= 0 ? true : false;
|
|
+
|
|
+ info->mem_swapped_out = dev->stats[VIRTIO_BALLOON_S_SWAP_OUT];
|
|
+ info->has_mem_swapped_out = info->mem_swapped_out >= 0 ? true : false;
|
|
+
|
|
+ info->major_page_faults = dev->stats[VIRTIO_BALLOON_S_MAJFLT];
|
|
+ info->has_major_page_faults = info->major_page_faults >= 0 ? true : false;
|
|
+
|
|
+ info->minor_page_faults = dev->stats[VIRTIO_BALLOON_S_MINFLT];
|
|
+ info->has_minor_page_faults = info->minor_page_faults >= 0 ? true : false;
|
|
+
|
|
+ info->free_mem = dev->stats[VIRTIO_BALLOON_S_MEMFREE];
|
|
+ info->has_free_mem = info->free_mem >= 0 ? true : false;
|
|
+
|
|
+ info->total_mem = dev->stats[VIRTIO_BALLOON_S_MEMTOT];
|
|
+ info->has_total_mem = info->total_mem >= 0 ? true : false;
|
|
}
|
|
|
|
static void virtio_balloon_to_target(void *opaque, ram_addr_t target)
|
|
diff --git a/monitor/hmp-cmds.c b/monitor/hmp-cmds.c
|
|
index 634968498b..5482dd0569 100644
|
|
--- a/monitor/hmp-cmds.c
|
|
+++ b/monitor/hmp-cmds.c
|
|
@@ -708,7 +708,35 @@ void hmp_info_balloon(Monitor *mon, const QDict *qdict)
|
|
return;
|
|
}
|
|
|
|
- monitor_printf(mon, "balloon: actual=%" PRId64 "\n", info->actual >> 20);
|
|
+ monitor_printf(mon, "balloon: actual=%" PRId64, info->actual >> 20);
|
|
+ monitor_printf(mon, " max_mem=%" PRId64, info->max_mem >> 20);
|
|
+ if (info->has_total_mem) {
|
|
+ monitor_printf(mon, " total_mem=%" PRId64, info->total_mem >> 20);
|
|
+ }
|
|
+ if (info->has_free_mem) {
|
|
+ monitor_printf(mon, " free_mem=%" PRId64, info->free_mem >> 20);
|
|
+ }
|
|
+
|
|
+ if (info->has_mem_swapped_in) {
|
|
+ monitor_printf(mon, " mem_swapped_in=%" PRId64, info->mem_swapped_in);
|
|
+ }
|
|
+ if (info->has_mem_swapped_out) {
|
|
+ monitor_printf(mon, " mem_swapped_out=%" PRId64, info->mem_swapped_out);
|
|
+ }
|
|
+ if (info->has_major_page_faults) {
|
|
+ monitor_printf(mon, " major_page_faults=%" PRId64,
|
|
+ info->major_page_faults);
|
|
+ }
|
|
+ if (info->has_minor_page_faults) {
|
|
+ monitor_printf(mon, " minor_page_faults=%" PRId64,
|
|
+ info->minor_page_faults);
|
|
+ }
|
|
+ if (info->has_last_update) {
|
|
+ monitor_printf(mon, " last_update=%" PRId64,
|
|
+ info->last_update);
|
|
+ }
|
|
+
|
|
+ monitor_printf(mon, "\n");
|
|
|
|
qapi_free_BalloonInfo(info);
|
|
}
|
|
diff --git a/qapi/machine.json b/qapi/machine.json
|
|
index d25a481ce4..3627172aed 100644
|
|
--- a/qapi/machine.json
|
|
+++ b/qapi/machine.json
|
|
@@ -1018,10 +1018,30 @@
|
|
# @actual: the logical size of the VM in bytes
|
|
# Formula used: logical_vm_size = vm_ram_size - balloon_size
|
|
#
|
|
+# @last_update: time when stats got updated from guest
|
|
+#
|
|
+# @mem_swapped_in: number of pages swapped in within the guest
|
|
+#
|
|
+# @mem_swapped_out: number of pages swapped out within the guest
|
|
+#
|
|
+# @major_page_faults: number of major page faults within the guest
|
|
+#
|
|
+# @minor_page_faults: number of minor page faults within the guest
|
|
+#
|
|
+# @free_mem: amount of memory (in bytes) free in the guest
|
|
+#
|
|
+# @total_mem: amount of memory (in bytes) visible to the guest
|
|
+#
|
|
+# @max_mem: amount of memory (in bytes) assigned to the guest
|
|
+#
|
|
# Since: 0.14
|
|
#
|
|
##
|
|
-{ 'struct': 'BalloonInfo', 'data': {'actual': 'int' } }
|
|
+{ 'struct': 'BalloonInfo',
|
|
+ 'data': {'actual': 'int', '*last_update': 'int', '*mem_swapped_in': 'int',
|
|
+ '*mem_swapped_out': 'int', '*major_page_faults': 'int',
|
|
+ '*minor_page_faults': 'int', '*free_mem': 'int',
|
|
+ '*total_mem': 'int', 'max_mem': 'int' } }
|
|
|
|
##
|
|
# @query-balloon:
|