c1cd6a6221
Most importantly the first one "Revert "monitor: use aio_co_reschedule_self()"", fixing a crash when doing hotplug+resize with a disk using io_uring. Other fixes (likely not too important) for TCG emulation of x86(_64) and ARM. Signed-off-by: Fiona Ebner <f.ebner@proxmox.com>
31 lines
1.3 KiB
Diff
31 lines
1.3 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Paolo Bonzini <pbonzini@redhat.com>
|
|
Date: Sat, 25 May 2024 10:03:22 +0200
|
|
Subject: [PATCH] target/i386: no single-step exception after MOV or POP SS
|
|
|
|
Intel SDM 18.3.1.4 "If an occurrence of the MOV or POP instruction
|
|
loads the SS register executes with EFLAGS.TF = 1, no single-step debug
|
|
exception occurs following the MOV or POP instruction."
|
|
|
|
Cc: qemu-stable@nongnu.org
|
|
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
(cherry picked from commit f0f0136abba688a6516647a79cc91e03fad6d5d7)
|
|
Signed-off-by: Fiona Ebner <f.ebner@proxmox.com>
|
|
---
|
|
target/i386/tcg/translate.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/target/i386/tcg/translate.c b/target/i386/tcg/translate.c
|
|
index c2c5e73b3f..a55df176c6 100644
|
|
--- a/target/i386/tcg/translate.c
|
|
+++ b/target/i386/tcg/translate.c
|
|
@@ -2817,7 +2817,7 @@ do_gen_eob_worker(DisasContext *s, bool inhibit, bool recheck_tf, bool jr)
|
|
if (recheck_tf) {
|
|
gen_helper_rechecking_single_step(tcg_env);
|
|
tcg_gen_exit_tb(NULL, 0);
|
|
- } else if (s->flags & HF_TF_MASK) {
|
|
+ } else if ((s->flags & HF_TF_MASK) && !inhibit) {
|
|
gen_helper_single_step(tcg_env);
|
|
} else if (jr &&
|
|
/* give irqs a chance to happen */
|