99c80e7492
As reported in the community forum [0], doing a snapshot without saving the VM state for a VM with a VirtIO block device with iothread would lead to an assertion failure [1] and thus crash. The issue is that vm_start() is called from the coroutine qmp_savevm_end() which violates assumptions about graph locking down the line. Factor out the part of qmp_savevm_end() that actually needs to be a coroutine into a separate helper and turn qmp_savevm_end() into a non-coroutine, so that it can call vm_start() safely. The issue is likely not new, but was exposed by the recent graph locking rework introducing stricter checks. The issue does not occur when saving the VM state, because then the non-coroutine process_savevm_finalize() will already call vm_start() before qmp_savevm_end(). [0]: https://forum.proxmox.com/threads/149883/ [1]: > #0 0x00007353e6096e2c __pthread_kill_implementation (libc.so.6 + 0x8ae2c) > #1 0x00007353e6047fb2 __GI_raise (libc.so.6 + 0x3bfb2) > #2 0x00007353e6032472 __GI_abort (libc.so.6 + 0x26472) > #3 0x00007353e6032395 __assert_fail_base (libc.so.6 + 0x26395) > #4 0x00007353e6040eb2 __GI___assert_fail (libc.so.6 + 0x34eb2) > #5 0x0000592002307bb3 bdrv_graph_rdlock_main_loop (qemu-system-x86_64 + 0x83abb3) > #6 0x00005920022da455 bdrv_change_aio_context (qemu-system-x86_64 + 0x80d455) > #7 0x00005920022da6cb bdrv_try_change_aio_context (qemu-system-x86_64 + 0x80d6cb) > #8 0x00005920022fe122 blk_set_aio_context (qemu-system-x86_64 + 0x831122) > #9 0x00005920021b7b90 virtio_blk_start_ioeventfd (qemu-system-x86_64 + 0x6eab90) > #10 0x0000592002022927 virtio_bus_start_ioeventfd (qemu-system-x86_64 + 0x555927) > #11 0x0000592002066cc4 vm_state_notify (qemu-system-x86_64 + 0x599cc4) > #12 0x000059200205d517 vm_prepare_start (qemu-system-x86_64 + 0x590517) > #13 0x000059200205d56b vm_start (qemu-system-x86_64 + 0x59056b) > #14 0x00005920020a43fd qmp_savevm_end (qemu-system-x86_64 + 0x5d73fd) > #15 0x00005920023f3749 qmp_marshal_savevm_end (qemu-system-x86_64 + 0x926749) > #16 0x000059200242f1d8 qmp_dispatch (qemu-system-x86_64 + 0x9621d8) > #17 0x000059200238fa98 monitor_qmp_dispatch (qemu-system-x86_64 + 0x8c2a98) > #18 0x000059200239044e monitor_qmp_dispatcher_co (qemu-system-x86_64 + 0x8c344e) > #19 0x000059200245359b coroutine_trampoline (qemu-system-x86_64 + 0x98659b) > #20 0x00007353e605d9c0 n/a (libc.so.6 + 0x519c0) Signed-off-by: Fiona Ebner <f.ebner@proxmox.com>
218 lines
7.6 KiB
Diff
218 lines
7.6 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Wolfgang Bumiller <w.bumiller@proxmox.com>
|
|
Date: Mon, 4 May 2020 11:05:08 +0200
|
|
Subject: [PATCH] PVE: add optional buffer size to QEMUFile
|
|
|
|
So we can use a 4M buffer for savevm-async which should
|
|
increase performance storing the state onto ceph.
|
|
|
|
Signed-off-by: Wolfgang Bumiller <w.bumiller@proxmox.com>
|
|
[increase max IOV count in QEMUFile to actually write more data]
|
|
Signed-off-by: Stefan Reiter <s.reiter@proxmox.com>
|
|
Signed-off-by: Thomas Lamprecht <t.lamprecht@proxmox.com>
|
|
[FE: adapt to removal of QEMUFileOps]
|
|
Signed-off-by: Fiona Ebner <f.ebner@proxmox.com>
|
|
---
|
|
migration/qemu-file.c | 50 +++++++++++++++++++++++++++-------------
|
|
migration/qemu-file.h | 2 ++
|
|
migration/savevm-async.c | 5 ++--
|
|
3 files changed, 39 insertions(+), 18 deletions(-)
|
|
|
|
diff --git a/migration/qemu-file.c b/migration/qemu-file.c
|
|
index a10882d47f..19c1de0472 100644
|
|
--- a/migration/qemu-file.c
|
|
+++ b/migration/qemu-file.c
|
|
@@ -35,8 +35,8 @@
|
|
#include "rdma.h"
|
|
#include "io/channel-file.h"
|
|
|
|
-#define IO_BUF_SIZE 32768
|
|
-#define MAX_IOV_SIZE MIN_CONST(IOV_MAX, 64)
|
|
+#define DEFAULT_IO_BUF_SIZE 32768
|
|
+#define MAX_IOV_SIZE MIN_CONST(IOV_MAX, 256)
|
|
|
|
struct QEMUFile {
|
|
QIOChannel *ioc;
|
|
@@ -44,7 +44,8 @@ struct QEMUFile {
|
|
|
|
int buf_index;
|
|
int buf_size; /* 0 when writing */
|
|
- uint8_t buf[IO_BUF_SIZE];
|
|
+ size_t buf_allocated_size;
|
|
+ uint8_t *buf;
|
|
|
|
DECLARE_BITMAP(may_free, MAX_IOV_SIZE);
|
|
struct iovec iov[MAX_IOV_SIZE];
|
|
@@ -101,7 +102,9 @@ int qemu_file_shutdown(QEMUFile *f)
|
|
return 0;
|
|
}
|
|
|
|
-static QEMUFile *qemu_file_new_impl(QIOChannel *ioc, bool is_writable)
|
|
+static QEMUFile *qemu_file_new_impl(QIOChannel *ioc,
|
|
+ bool is_writable,
|
|
+ size_t buffer_size)
|
|
{
|
|
QEMUFile *f;
|
|
|
|
@@ -110,6 +113,8 @@ static QEMUFile *qemu_file_new_impl(QIOChannel *ioc, bool is_writable)
|
|
object_ref(ioc);
|
|
f->ioc = ioc;
|
|
f->is_writable = is_writable;
|
|
+ f->buf_allocated_size = buffer_size;
|
|
+ f->buf = malloc(buffer_size);
|
|
|
|
return f;
|
|
}
|
|
@@ -120,17 +125,27 @@ static QEMUFile *qemu_file_new_impl(QIOChannel *ioc, bool is_writable)
|
|
*/
|
|
QEMUFile *qemu_file_get_return_path(QEMUFile *f)
|
|
{
|
|
- return qemu_file_new_impl(f->ioc, !f->is_writable);
|
|
+ return qemu_file_new_impl(f->ioc, !f->is_writable, DEFAULT_IO_BUF_SIZE);
|
|
}
|
|
|
|
QEMUFile *qemu_file_new_output(QIOChannel *ioc)
|
|
{
|
|
- return qemu_file_new_impl(ioc, true);
|
|
+ return qemu_file_new_impl(ioc, true, DEFAULT_IO_BUF_SIZE);
|
|
+}
|
|
+
|
|
+QEMUFile *qemu_file_new_output_sized(QIOChannel *ioc, size_t buffer_size)
|
|
+{
|
|
+ return qemu_file_new_impl(ioc, true, buffer_size);
|
|
}
|
|
|
|
QEMUFile *qemu_file_new_input(QIOChannel *ioc)
|
|
{
|
|
- return qemu_file_new_impl(ioc, false);
|
|
+ return qemu_file_new_impl(ioc, false, DEFAULT_IO_BUF_SIZE);
|
|
+}
|
|
+
|
|
+QEMUFile *qemu_file_new_input_sized(QIOChannel *ioc, size_t buffer_size)
|
|
+{
|
|
+ return qemu_file_new_impl(ioc, false, buffer_size);
|
|
}
|
|
|
|
/*
|
|
@@ -328,7 +343,7 @@ static ssize_t coroutine_mixed_fn qemu_fill_buffer(QEMUFile *f)
|
|
do {
|
|
len = qio_channel_read(f->ioc,
|
|
(char *)f->buf + pending,
|
|
- IO_BUF_SIZE - pending,
|
|
+ f->buf_allocated_size - pending,
|
|
&local_error);
|
|
if (len == QIO_CHANNEL_ERR_BLOCK) {
|
|
if (qemu_in_coroutine()) {
|
|
@@ -368,6 +383,9 @@ int qemu_fclose(QEMUFile *f)
|
|
ret = ret2;
|
|
}
|
|
g_clear_pointer(&f->ioc, object_unref);
|
|
+
|
|
+ free(f->buf);
|
|
+
|
|
error_free(f->last_error_obj);
|
|
g_free(f);
|
|
trace_qemu_file_fclose();
|
|
@@ -416,7 +434,7 @@ static void add_buf_to_iovec(QEMUFile *f, size_t len)
|
|
{
|
|
if (!add_to_iovec(f, f->buf + f->buf_index, len, false)) {
|
|
f->buf_index += len;
|
|
- if (f->buf_index == IO_BUF_SIZE) {
|
|
+ if (f->buf_index == f->buf_allocated_size) {
|
|
qemu_fflush(f);
|
|
}
|
|
}
|
|
@@ -441,7 +459,7 @@ void qemu_put_buffer(QEMUFile *f, const uint8_t *buf, size_t size)
|
|
}
|
|
|
|
while (size > 0) {
|
|
- l = IO_BUF_SIZE - f->buf_index;
|
|
+ l = f->buf_allocated_size - f->buf_index;
|
|
if (l > size) {
|
|
l = size;
|
|
}
|
|
@@ -587,8 +605,8 @@ size_t coroutine_mixed_fn qemu_peek_buffer(QEMUFile *f, uint8_t **buf, size_t si
|
|
size_t index;
|
|
|
|
assert(!qemu_file_is_writable(f));
|
|
- assert(offset < IO_BUF_SIZE);
|
|
- assert(size <= IO_BUF_SIZE - offset);
|
|
+ assert(offset < f->buf_allocated_size);
|
|
+ assert(size <= f->buf_allocated_size - offset);
|
|
|
|
/* The 1st byte to read from */
|
|
index = f->buf_index + offset;
|
|
@@ -638,7 +656,7 @@ size_t coroutine_mixed_fn qemu_get_buffer(QEMUFile *f, uint8_t *buf, size_t size
|
|
size_t res;
|
|
uint8_t *src;
|
|
|
|
- res = qemu_peek_buffer(f, &src, MIN(pending, IO_BUF_SIZE), 0);
|
|
+ res = qemu_peek_buffer(f, &src, MIN(pending, f->buf_allocated_size), 0);
|
|
if (res == 0) {
|
|
return done;
|
|
}
|
|
@@ -672,7 +690,7 @@ size_t coroutine_mixed_fn qemu_get_buffer(QEMUFile *f, uint8_t *buf, size_t size
|
|
*/
|
|
size_t coroutine_mixed_fn qemu_get_buffer_in_place(QEMUFile *f, uint8_t **buf, size_t size)
|
|
{
|
|
- if (size < IO_BUF_SIZE) {
|
|
+ if (size < f->buf_allocated_size) {
|
|
size_t res;
|
|
uint8_t *src = NULL;
|
|
|
|
@@ -697,7 +715,7 @@ int coroutine_mixed_fn qemu_peek_byte(QEMUFile *f, int offset)
|
|
int index = f->buf_index + offset;
|
|
|
|
assert(!qemu_file_is_writable(f));
|
|
- assert(offset < IO_BUF_SIZE);
|
|
+ assert(offset < f->buf_allocated_size);
|
|
|
|
if (index >= f->buf_size) {
|
|
qemu_fill_buffer(f);
|
|
@@ -811,7 +829,7 @@ static int qemu_compress_data(z_stream *stream, uint8_t *dest, size_t dest_len,
|
|
ssize_t qemu_put_compression_data(QEMUFile *f, z_stream *stream,
|
|
const uint8_t *p, size_t size)
|
|
{
|
|
- ssize_t blen = IO_BUF_SIZE - f->buf_index - sizeof(int32_t);
|
|
+ ssize_t blen = f->buf_allocated_size - f->buf_index - sizeof(int32_t);
|
|
|
|
if (blen < compressBound(size)) {
|
|
return -1;
|
|
diff --git a/migration/qemu-file.h b/migration/qemu-file.h
|
|
index 32fd4a34fd..36a0cd8cc8 100644
|
|
--- a/migration/qemu-file.h
|
|
+++ b/migration/qemu-file.h
|
|
@@ -30,7 +30,9 @@
|
|
#include "io/channel.h"
|
|
|
|
QEMUFile *qemu_file_new_input(QIOChannel *ioc);
|
|
+QEMUFile *qemu_file_new_input_sized(QIOChannel *ioc, size_t buffer_size);
|
|
QEMUFile *qemu_file_new_output(QIOChannel *ioc);
|
|
+QEMUFile *qemu_file_new_output_sized(QIOChannel *ioc, size_t buffer_size);
|
|
int qemu_fclose(QEMUFile *f);
|
|
|
|
/*
|
|
diff --git a/migration/savevm-async.c b/migration/savevm-async.c
|
|
index 72cf6588c2..fb4e8ea689 100644
|
|
--- a/migration/savevm-async.c
|
|
+++ b/migration/savevm-async.c
|
|
@@ -379,7 +379,7 @@ void qmp_savevm_start(const char *statefile, Error **errp)
|
|
|
|
QIOChannel *ioc = QIO_CHANNEL(qio_channel_savevm_async_new(snap_state.target,
|
|
&snap_state.bs_pos));
|
|
- snap_state.file = qemu_file_new_output(ioc);
|
|
+ snap_state.file = qemu_file_new_output_sized(ioc, 4 * 1024 * 1024);
|
|
|
|
if (!snap_state.file) {
|
|
error_set(errp, ERROR_CLASS_GENERIC_ERROR, "failed to open '%s'", statefile);
|
|
@@ -503,7 +503,8 @@ int load_snapshot_from_blockdev(const char *filename, Error **errp)
|
|
blk_op_block_all(be, blocker);
|
|
|
|
/* restore the VM state */
|
|
- f = qemu_file_new_input(QIO_CHANNEL(qio_channel_savevm_async_new(be, &bs_pos)));
|
|
+ f = qemu_file_new_input_sized(QIO_CHANNEL(qio_channel_savevm_async_new(be, &bs_pos)),
|
|
+ 4 * 1024 * 1024);
|
|
if (!f) {
|
|
error_setg(errp, "Could not open VM state file");
|
|
goto the_end;
|