6e72c5b2b7
long overdue, and avoids the issue of the meta packages version going down after being folded in from the pve-kernel-meta repository. the ABI needs to be bumped for every published kernel package now that modules are signed, else the booted kernel image containing the public part of the ephemeral signing key, and the on-disk (potentially upgraded in-place) signed module files can disagree, and module loading would fail. not changed (yet): git repository name, pve-firmware Signed-off-by: Fabian Grünbichler <f.gruenbichler@proxmox.com>
18 lines
348 B
Bash
Executable File
18 lines
348 B
Bash
Executable File
#! /bin/sh
|
|
|
|
# Abort if any command returns an error value
|
|
set -e
|
|
|
|
case "$1" in
|
|
configure)
|
|
# setup kernel links for installation CD (rescue boot)
|
|
mkdir -p /boot/pve
|
|
ln -sf /boot/vmlinuz-@@KVNAME@@ /boot/pve/vmlinuz-@@KVMAJMIN@@
|
|
ln -sf /boot/initrd.img-@@KVNAME@@ /boot/pve/initrd.img-@@KVMAJMIN@@
|
|
;;
|
|
esac
|
|
|
|
#DEBHELPER#
|
|
|
|
exit 0
|